The problem comes from the "Stay signed in?" prompt sent by Microsoft Entra during the first SSO connection of a non-registered user.
When a non-registered user tries to book a room on a RoomPad that requires SSO authentication, the following flow occurs:
1. A webview displaying the Microsoft login page is shown. 2. The user enters their login and password. 3. A webview asking whether the user wants to stay signed in appears. 4. The user can then confirm the room booking.
This flow occurs only during the first booking, regardless of whether the user chooses to stay signed in or not.
On a RoomPad 1050, the "Stay signed in?" prompt does not display properly and blocks the flow. The process works correctly on the 1050 Pro and on all other devices we have tested.
We are currently investigating this issue with QBic to determine whether it can be resolved.
Workarounds : - Disable the "Stay signed in?" prompt in your Microsoft Entra configuration. - Perform the first booking for new users on another QBic device (1050 Pro, 1070, etc.). - Pre-register users on the platform before their first booking.
Posted Mar 11, 2026 - 18:02 CET
Identified
A problem has been identified on the identification flow. A fix is currently tested on part of our fleet
Posted Mar 10, 2026 - 21:02 CET
Update
We are continuing to investigate this issue.
Posted Mar 10, 2026 - 18:42 CET
Update
We are continuing to investigate this issue.
Posted Mar 10, 2026 - 18:42 CET
Investigating
Symptoms are that the authentication for 1050 Roompads when badging takes ages, sometimes resulting in a black pop up, or even a timeout. cookie_not_found error is returned on Graylog, alongside with IDENTITY_PROVIDER_LOGIN_ERROR